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OpenLDAP

1. To install OpenLDAP Server

OpenLDAP Server is free available from:
http://www.openldap.org/software/download/

1.1 Double click the OpenLDAP application to start the installation:
For example: openldap-2.2.29-db-4.3.29-openssl-0.9.8a-win32_Setup.exe

V':'_\I Setup — OpenLDAP ! \ |X‘

Welcome to the OpenLDAP Setup
Wizard

This will install openldap-2.2.29 on your computer.

Itis recommended that you close all other applications before
continuing.

Click Next to continue, or Cancel to exit Setup.

[ Next > ,I[ Cancel ]

License Agreement
Please read the following important information before continuing.

Please read the following License Agreement. You must accept the terms of this
agreement before continuing with the installation.

The OpenLDAP Public License
Wersion 2.8, 17 August 2003

[

Redistribution and use of this software and associated documentation
["Software"), with or without modification, are permitted provided
that the following conditions are met:

1. Redistributions in source form must retain copyright statements
and notices,

2. Redistributions in binary form must reproduce applicable copyright

€

@ | accept the agreement
(O | do not accept the agreement

[ < Back ][ Next > ][ Cancel ]

1.2 Click "Browse" to locate the installation path(for example: c:\OpenLDAP),
and then click "Next".


http://www.openldap.org/software/download/
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Select Destination Location
‘Where should OpenLDAP be installed?

‘/’ Setup will install 0penLDAP into the following folder,

To continue, click Next. If you would like to select a different folder, click Browse.
l [ Browse... ]

|C:\OpenLDAP

At least 0.7 MB of free disk space is required.

[ < Back " Next > ][ Cancel ]

1.3 Select "Full installation" as below and click "Next" to continue.

]’.;.EL Setup — OpenlLDAP

Select Components
‘wihich components should be installed?

Select the components you want to install; clear the components you do not want to
inztall. Click Mext when pou are ready to continue.

(®) install DpenLD&P openldap-2.2.29 10,7 MB
03ME

install BDB-tocks

install OpenLDAP-slapd as NT service
[ install OpenLD&P-shupd as NT service

Current selection requires at least 11.4 MB of disk space.

< Back ” Mest > ][ Cancel

1.4 Click "Next/Install" as Default setting.

]’.;.EL Setup — OpenlLDAP

Select Start Menu Folder
‘wihere should Setup place the program's shortcuts ?

Setup will create the program's shortcuts in the following Start Menu folder.

To continue, click Mest. If pou would like to select a different folder, click Browse.

| [ Browse... ]

[] Don't create a Start Menu folder

< Back ” Mest > ][ Cancel
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]'.:.E! Setup — OpenlDAP

Select Additional Tasks
‘which additional tasks should be performed?

Select the additional task s you would like Setup to perfarm while installing OpenlDAP,
then click Mest.

Additional icons:

tomatically start OpenLDAP NT service(s] after reboat

[ Create a deskiop icon

]'.;.E! Setup — OpenLDAP

Ready to Install

Setup iz now ready to begin installing OpenlDAP an your computer.

Click Inztall to continue with the installation, or click Back if you want ta review or
change any zettings.

Destination location:
C:AOpenLDAP

>

Setup type:
Fuill installation

Selected components:
install OpenlLDAP openldap-2.2.29
install EDB-tools
install OpenLDAP-glapd as NT service -

Start Menu folder:
OpenlDAP

| €

< Back ]| Inztall |[ Cancel

1.5 Click "Finish" to complete the OpenLDAP installation.

]'.;.E! Setup — OpenLDAP

Completing the OpenLDAP Setup
Wizard

To complete the installation of 0penlLDAP, Setup must restart
your computer. YWwould wou like to restart now?

®¥es, 1estar the computer now

() Mo, | will restart the computer later
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2. To configure the LDAP Server

2.1 Add the schema commands.
Open the slap.conf file under the installation path. And find the

command :./schema/core.schema, and then add the following commands:

include ./schema/cosine.schema
include .Jschemalinetorgperson.schema
include ./schemal/corba.schema
include .Jschema/dyngroup.schema
include ./schemaljava.schema
include ./schema/misc.schema
include ./schema/nis.schema
include ./schema/openldap.schema

#

# See =lapd. conf (5]} for details on configuration options.
# Thi=s file should NOT be world readable.

#

ucdata—path . ucdata

bnclude ./ =zchema’ core. schema |
mechde Sachemalcosine schema
meclude Sschemafinetorgperson schema
mclude Sschemalcorba schema

mclude Jschemaldyngroup. schema
mclude JSschemaljava. schema

mechde Sachemadmizc schema

mclude JSschemafis schema

Iinc:lude Jschemalopenldap . schema

# Define global ACLzs to disable default read access.

# Do not enable referrals until AFTEE wou hawve a working dire:
# zervice AND an undersztanding of referrals.
#freferral ldap:/root. openldap. org

pidfile Srundzlapd. pid
arg=zfile LArunslapd. args

Load dynamic backend modules:
modulepath . /libexec/openldap
moduleload baclk bdb. 1a
moduleload back_ldap. la
moduleload baclk_ldbm. 1a
moduleload back pazswd. 1la

FHOoH R o R H

2.2 Edit the manager information:

Find the following commands in slap.conf:

suffix “dc=my-domain, dc=com”

rootdn “cn=manager,dc=mg-domain,dc=com”
rootpw secret
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suffix defines the components of the domain name.
rootdn is the manager access to the LDAP server.
rootpw means the password of the manager.

For example, you can change the context as following:
suffix ~ “dc=HanLong,dc= com”

rootdn “cn=manager,dc=HanLong,dc= com’

rootpw  secret

dat aba=e bdh
ULLLlx C=Iy— QOmalll, do—Com

Cr=MArager, do—my— domadlrl, 00— Con
EAILEXI DAz=WOrds, Ezpeclallw Lor g rootdr, =hould

# be awoid. See slappasswdi(8) and =lapd. conf (5] for details.
# Uze of ztrong authentication encouraged.

LéE;tpw zecret I
he databasze directory MUST exist prior to running =zlapd ANI
# zhould only be acceszible by the zlapd and =lap tools.
# Mode TOO recommended.
directory Lidata
# Indices to maintaid
index objectClazs eq

databaze bdhb
fuffix "de=HanLong, do=com” |
Qo cn=Manager, dc=Hanlong, dc=com

Lleartext pazaswords, especially for the rootdn, should
# be awoid. See =lappasswd(8) and =lapd. conf(5) for details.
# Usze of ztrong authentication encouraged.
aotpr Zecre
# The databaze directory MUST exist prior to runnming =zlapd ANI
# zhould onlv be acceszszible by the =lapd and =lap tools.
# Mode TOO recommended.
directory LAdata
# Indicesz to maintain
index objectClazzs eqg

3. To Run Slapd Server

3.1 Click Start> Run—> input cmd-> Enter.

3.2 Perform the cd command to locate the server installation path.
For example: input cd c:\OpenLDAP(c:\OpenLDAP)
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v CzAFIRDOWS\ systen3i?\ocnd. exe

oCuREnts an 3 od cisDpenLDAP

Gz “OpanLDAP >

enLDAP

i.H HAHE
rtad Foatur

=Han Long . dec=com""

dided T¥GER
: listen=1BE6R active_threads=8 tup=HULL

Note: Keep the window open to ensure the server is running.

4. To add initial Entry to the LDAP Directory

4.1 Create .ldif file under the located path.
For example: create a file test.Idif under c:\OpenLDAP.
Input the following context in the .Idif file and save.

dn:dc=HanLong,dc= com
objectclass:dcobject
objectclass:organization
o:xmHanLong
dc:HanLong
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dn:cn=manager,dc=HanLong,dc= com
dc=HanLong

objectclass:dcobject
objectclass:organization

cn=manager

sn:summer

e & #

dn:doc=HanLong, do= com
objectclazs:idoobject
objectclass:organization
oremHanl ong

dc:Hanlong

dn: cn=manager, de=HanLong, de= com
do=HanLong

objectclazs:idoobject
objectclaz=s:organization
CH=Manager

SN SUmer

4.2 To make the Entry effective.
4.2.1 Click start->run->Enter cmd->Enter
4.2.2 Input cd c:\OpenLDAP

4.2.3 Input Idapadd —x —D “cn=manager,dc=HanLong,dc=com” —w secret —f test.dif

C:\WINDO¥5isysteniZ2\cad. exe

Windows XP [fFZN 5.1.26801
‘H 1985-2081 Microsoft Corp.

C:“Documents and Settingssmax>cd c:“0penLDAF

C:~0penLDAP>1dapadd —-x —-D “cn=manager.dc=HanLong,.dc=com'" —-w secret —f test.ldif
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5. To Install LDAP Client

LDAPExploreTool2 is free on web http://Idaptool.sourceforge.net/.

5.1 Double click LDAPExploreTool2.exe, and then click "Next".

]lgil Setup — LDAPExplorerTool 2 E“Elg]

Welcome to the
LDAPExplorerTool 2 Setup Wizard
Thig will inztall LDAPEsplorerT ool 2 on your computer.

It iz recommended that vou close all other applications before
continuing.

Click Mest to continue, or Cancel to exit Setup,

1'.;21 Setup — LDAPExzplorerTool 2

Licenze Agreement
Pleaze read the follawing impartant information befare continuing.

Pleaze read the following License Agreement. You must accept the terms of this
agreement before continuing with the installation.

Copyright (=] 2006, Laurent Ulich ~
All rightz reserved.

Redistribution and uze in source and binary farms, with or without modification, are
permitted pravided that the following conditions are met:

* Redistnbutions of source code must retain the abowve copyright notice, this list of
conditionz and the following disclaimer.

* Redistributions in binary form must reproduce the abave copynght notice, this
ligt af conditions and the following dizclaimer in the documentation and/or other
materialz provided with the distribution. v

()1 do nat accept the agreement

< Back " Meut > l[ Cancel

5.2 Select the installation and then click "Next" as default setting.

10
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]';.El Setup — LDAPEzplorerTool 2

Select Destination Location ”
“Where should LDAPE splorerT ool 2 be installed?

‘J Setup will install LDAPE xplorerTool 2 into the following folder.

To continue, click Mest. If you would like to select a different folder, click Browse.

| ’ Browse. .

At least 18.2 ME of free disk space iz required.

< Back " Mext > l[ Cancel ]

]'.;.E‘ﬂ Setup — LDAPEzplorerTool 2

Select Start Menu Folder
“Where should Setup place the program's shortcuts™

Setup will create the program's shartcuts in the following Start Menu folder.

To caontinue, click Mest. If you waould like to zelect a different folder, click Erowse.

| [ Browse...

[ Don't create a Start Meru falder

< Back " Mext » ]’ Cancel ]

]'.;.El Setup — LDAPEzplorerTool 2

Select Additional Tasks H
Wwhich additional tasks should be performed? =

Select the additional tasks pou would like 5 etup to perform while installing
LDAPE =plorerT ool 2, then click Mest.

Additional icons:

[ Create a Quick Launch icon

< Back ” Mest » l[ Cancel
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]'.;E* Setup — LDAPEzplorerTool 2

Ready to Install H
Setup iz now ready to begin inztaling LOAPE=plorerT ool 2 on your computer.

Click Install to continue with the installation, or click Back if you want to review or
change any settings.

Crestination location:
C:\Program Files\LDAPE=plorerToal 2

Start Menu folder:
LDAPE =plorerToal 2

Additional tazks:
Additional icons:
Create a desktop icon

’ <Back |[ Instal |’ Cancel

5.3 Click "Finish" to finish the installation.

]'.;E! Setup — LDAPEzplorerTool 2 E“E“E

Completing the LDAPExplorerTool
2 Setup Wizard

Setup has finished installing LDAPE xplorerTool 2 on pour
computer. The application may be launched by selecting the
installed icons.,

Click Finizh to exit Setup.

‘Launch LDAPEsplarerT ool 2

6. To Configure LDAP Client

6.1 Run LDAPEXxploreTool2.
Double click LDAPExploreTool Icon on the table.

I LDAPEzplore. . . g@@l

File Taool=s

6.2 To Create a Configuration.

12
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6.2.1 Click File->Configuration>New, to add a new configuration.

Il LDAPExplorerTool 2

Open last configuration

Quit !

Configurations

6.2.2 Fill the Configuration name, for example: LDAP.

Configurstion

Immlmlmsl

Fowifigur ation narme fowr

ok | concel |

6.2.3 Fill the Server Name or IP under Server table, for example: 192.168.0.90. Leave the
Server port and Server SSL port as default.

13
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X

Configuration

Configuration CDnnectiDn] Optiun] SSLJ’TLS]

Eerver name or IP 192.168.0.124

Server port ‘@ V' Use default part

Server SSL port vV Use default port

Wersion

I0 .‘

Test connection

Ok | Canicel |

6.2.4 Under the Connection table, fill the User DN and Password.

The context filled on User DN is same as "rootdn" in .1dif file.

For example:

User ID: cn=manager,dc=HanLong,dc=com

Password: secret

Click the "Guess value" to get the base DN and then click "Test connection" to test the
connection status.

Configuration ] Server ptiun ] SSL}TLS]

Lizer DN Ch=manager,dc= [ Anonyrmous login
Pazswiord kit ok ¥ Store

Test Result D_?|

password

Use SSL port

C ves ® Mo \!‘) Test OK
Lz TLS

" Yes & No
Base DN dc=HanLong,dc=

Test connection

ik, | Cancel

6.2.5 Click "Ok" to finish the configuration.

|

14
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7. To Add contacts

7.1 Open the created configuration.
7.1.1 Click File=>Configuration->select the created configuration.

For example: LDAP

Configurations

Actions
Mew. ..
Jpen
Edit...

Delete...

7.1.2 Click "Open" to open the configuration.

7.2 To Add the new entry creation.
7.2.1 Right click the root entry and click the "Add" button to add new entries.

M LDAPEzplorerTool 2

File Jeools

| & dc-HaoLeng dc-con

Entry

Copy to. ..
Bunans, . .

Delete. ..

Sewrch. ..

15



[=l-Htek

New entry creation
Parent DN m

Entry RDMN ’7

Ohject class (from scherna) | ﬂ

Ohject class {manual) ’7

dc=HarLong,dc=corm

MUST attributes MAY attributes

Attribute( when schema Add
is unavailable)

Save | Cancel |

7.2.2 Fill the "Entry RDN" follow the format: cn=xxx, for example: cn=Alyssa.

7.2.3 Select the "Object Class", for example: person.

7.2.4 Double click the snin the "MUST attributes”, and then right click sn to fill the value:
For example Cheng.

Parert D sHanong,dc=
Entry RON nrssa
Object dass (from schemal) [person ]
Obiject class (manual)
= Cn= , 0 =Hanlong, O =com
Atiribates
Ramave atiribuiy
MUET attributes MAY attributes
EN (.serPassword
i tedephoretiumber
objectlss seefkn
desoription

Attributa( when schema Add
I5 unavallable ) 4|

16
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7.2.5 Double click cn in the "MUST attributes", and then right click cn to add the cn
value(the value is same as "Entry RDN", here for example is Alyssa).

Hew entry creation ,i}(
Parent DN [Ac=Harionn de=

ey i ]

Chyject class (from schema) [person =]

Cloject clats (marial)

MUST attribat,

Attribute] whien schema aod |

7.2.6 Double click "Object Class".

7.2.7 Double click the telephoneNumber in "May attributes”, and then right click to add the
value.

7.2.8 Click "Save" to save this Entry.

7.2.9 Repeat Step 7.2.1—7.2.8 to add more Entries.

Note:
1. sn means surname. cn means common name
2. "MUST attributes" must be selects, and "MAY attributes" is optional.

17
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8. To configure LDAP on Htek IP Phones

8.1 Login webpage and configure LDAP features.
Click Directory->LDAP

LDAP Name Filter: This parameter specifies the name attributes for LDAP searching. The
“%” symbol in the filter stands for the entering string used as the prefix of the filter
condition.

For example (cn=%), when the name prefix of the cn of the contact record matches the
search criteria, the record will be displayed on the IP PHONE LCD.

LDAP Number Filter: This parameter specifies the number attributes for LDAP searching.

Server Address: Fill the domain name or IP address of the LDAP Server.
For example: 192.168.0.124

Port: Fill the port of the LDAP Server, for example: 389 as default.

Base: Fill the same value as suffix value mentioned before.(On page 6)
For example: dc=HanLong,dc=com

User Name: Fill the same value as rootdn mentioned before.(On page 6 )
For example: cn=manager,dc=HanLong,dc=com

Password: Fill the same value as the rootpw mentioned before. (On page 6 )
For example: secret

Max.Hits: Fill the maximum number of the search results to be returned by the LDAP
server.

LDAP Name Attributes: Fill the LDAP Name Filter, separated by a space between two
values. If you set this attribute, the LDAP Server will send the name attribute to SIP Server,
for example: cn

LDAP Number Attributes: Fill the LDAP Number Filter, separated by a space between
two values. If you set this attribute, the LDAP Server will send the number attribute to SIP
Server, for example: telephoneNumber

LDAP Display Name: Fill the display name of the contact record displayed on the LCD
screen, separated by a space between two values, for example: %cn %sn

Filled the relative value and then click "SaveSet" button to save the settings.
Following is the example screenshot for the configuration.

18
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Home | Account | Network | Function Keys | Setting | | Management
Directory LOWP Mame Filier {cn="%) T NOTE
Remote Phone
Book LOWF Mumber Filter (litelephoneiumber=%) g
Ty Server Addrass 1921680124 y
Por 389 T
Network
Directory Base de=HanLong, dc=com ¥
WMulliCast Paging
User Mame er,dc=HanLong dc=com 2
Pagsword LTI T T
Max His(1~32000) 32000 2
LDAP Name Aftributes cn sn displayName ?
LDAP Number Attributes honeNumber homePho 2
LDAP Display Name %an %sn ?
Search Delay(0~2000ms) 2
Protocol () Version2 @ Version3 ?
LDAP Lookup For Call @ on Oon ?
LDAP Sorting Resuts © on Dot 2
LDAP Synchronize Time(0~3399mins) ?
[ saveset |

8.2 To Configure LDAP Key.
8.2.1 To configure LDAP Key via Web:

® Click Function Key—->Line Key-> choose Line Key 4(for example).
® Select LDAP in the Type field.
® Click "SaveSet" to save the configuration.

Home | Account | Network | | Setting | Directory | Management

Label Account Pickup Code NOTE
Keyl  Line - | [4ute = |

Memory Key

Prom?(:;mable Key2  Line - | [ [tuto B
Keyd  Line - | [4uta [=
EXP KEY
|Keya  LDaP ~ | | | Aute [-] |

8.2.2 To Configure LDAP Key via LCD:

® Press Menu->Feature—>Function Keys—>Memory Keys as Function Keys->Memory
Key 1.

® Select LDAP in the Type field.

® Press "Save" or "OK" key to save the configuration.

19
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9. To use LDAP on Htek IP Phones

Press the LDAP Key.

LDAP Contacts 1/68

navy 828
william 831
Simon 829

jack 817

nancy

Filter Prefix:

Cancel Delete Option

Active Directory

1. To install the Microsoft Active Directory Domain

Services

Note: This section shows you how to install an active directory on Microsoft Windows
Server 2008 or Microsoft Windows Server 2008 R2 Enterprise 64-bit system.

1.1 Click Start>Run.

1.2 Enter dcpromo in the pop-up dialogue box and click "ENTER".

1.3 The Active Directory Domain Services Installation Wizard will appear after a short
while, click "Next":

20
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@ Active Directory Domain Services Installation Wizard

Welcome to the Active Directory
Domain Services Installation
Wizard

This wizard helps you install Active Directory Domain
Services (AD DS) on this server, making the server an
Active Directory domain controller. To continue, click Next.

[ Use advanced mode installation

Leam more about the additional options that are
available in advanced mode installation.

More about Active Directory Domain Services

< Back Next > Cancel

1.4 Popup hint window, click "ok".
1.5 Read the provided information and click "Next":

21
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@! Active Directory Domain Services Installation Wizard

Operating System Compatibility
Improved security settings in Windows Server 2008 affect older versions of
Windows

/1. Windows Server 2008 domain controllers have a new more secure default for the

security setting named "Allow cryptography algorithms compatible with Windows NT
4.0." This setting prevents Microsoft Windows and non-Microsoft SMB "clients” from
using weaker NT 4.0 style cryptography algorithms when establishing security channel
sessions against Windows Server 2008 domain controllers. As a result of this new
default, operations or applications that require a security channel serviced by
Windows Server 2008 domain controllers might fail.

Platforms impacted by this change include Windows NT 4.0, as well as non-Microsoft
SMB "clients” and network-attached storage (NAS) devices that do not support
stronger cryptography algorithms. Some operations on clients running versions of
Windows earier than Vista with Service Pack 1 are also impacted, including domain
join operations performed by the Active Directory Migration Tool or Windows
Deployment Services.

For more information about this setting, see Knowledge Base atticle 542564
{http://go microsoft.com/fwlink/?Linkld=104751).

_ Concel |
1.6 Mark the "Create a new domain in a new forest" radio box and click "Next".

Note: We recommend that you set a strong password for the local Administrator
account before you create the new domain.

22
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o! Active Directory Domain Services Installation Wizard

Choose a Deployment Configuration
‘You can creabe a domain controfler for an existing forest orfor a new forest,

L Bdda domer cantiallen toan exisEing domaim:

L aoTiEnT cortnallen im e e domain.

@ ! Active Directory Domain Services Installation Wizard

Name the Forest Root Domain

The first domain in the forest is the forest root domain. lts name is also the name of
thefomd;

23
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The wizard will check if the domain name is in use on the local network:

Name the Forest Root Domain

The first domain in the forest is the forest root domain. lts name is also the name of
the forest.

1.8 Select the desired forest functional level from the pull-down list of "Forest functional
level", and click "Next".
For more information, click "domain and forest functional levels":

24
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@ Active Directory Domain Services Installation Wizard B x|

Set Forest Functional Level

Lx i

Select the forest functional level. =
Forest functional level:
Windows Server 2003 =

Details:

Windows Server 2003 forest functional level provides all features that are -
vailable in Windows 2000 forest functional level, and the following additional
eatures:

- Linked-value replication, which improves the replication of
changes to group memberships.

- More efficient generation of complex replication topologies
by the KCC.

- Forest trust, which allows organizations to easily share ;]

0 You will be able to add only domain controllers that are running
Windows Server 2003 or later to this forest.

More about domain and forest functional levels

< Back Next > Cancel

1.9 Select the desired domain functional level from the pull-down list of "Domain
functional level", and click "Next".

For more information, click "domain and forest functional levels".

25
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@ ! Active Directory Domain Services Installation Wizard

Set Domain Functional Level i
Select the domain functional level. £l

Domain functional level:
Windows Server 2003 i

Details:
following features are available at the Windows Server 2003 domain functional o

universal groups

group nesting

group type conversion

SID history

Constrained delegation, which an application can use to take

advantage of the secure delegation of user credentials by L'

1 You will be able to add only domain controllers that are running
K Windows Server 2003 or later to this domain.

More about domain and forest functional levels

<§ack|ﬂext>| Cancel

1.10 Select additional options for this domain controller if required, and click "Next".

26
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°:I Active Directory Domain Services Installation Wizard 5]

Select additional options for this domain controller.
v DNS server
¥ | Globalcatalog
I= | Bead-only domain controller (REDE]
Additional information:

The first domain controller in a forest must be a global catalog server and ;I
cannot be an RODC.

We recommend that you install the DNS Server service on the first domain
controller.

More about additional domain controller options

<Back [ Net> |  Cancel |

1.11 The wizard will prompt a warning about DNS delegation. Since no DNS has been
configured yet, you can ignore the message and click "Yes".

4 Adelegation for this DNS server cannot be created because the
l\ authoritative parent zone cannot be found or it does not run
~ Windows DNS server. If you are integrating with an existing DNS

infrastructure, you should manually create a delegation to this
DNS server in the parent zone to ensure reliable name resolution
from outside the domain petrilab.local. Otherwise, no action is
required.

Do you want to continue?

Yes%J No

1.12 Specify the desired paths for the database, log files and SYSVOL folders, and click
IINextll.
For more information, click "placing Active Directory Domain Services files".

27
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©! Active Directory Domain Services Installation Wizard x|
Location for Database. Log Files. and SYSVOL ‘ =
Specify the folders that will contain the Active Directory domain controller ==
database, log files, and SYSVOL. l

For better performance and recoverability, store the database and log files on separate
volumes.

Database folder:

AWindows\NTDS
Log files folder:

IC:\Windows\NTD S Browse...

SYSVOL folder:
IC:\Windows\SYSVOL

1.

More about placing Active Directory Domain Services files

< Back I Next > I Cancel

1.13 Configure the password for the active directory recovery mode, and click "Next".
For more information, click "Directory Services Restore Mode password".
The password should be complex and at least 7 characters long.
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©@! Active Directory Domain Services Installation Wizard

Directory Services Restore Mode Administrator Password

The Directory Services Restore Mode Administrator account is different from the domain

Administrator account.

Assign a password for the Administrator account that will be used when this domain

controller is started in Directory Services Restore Mode. We recommend that you
choose a strong password.

Password: [oeseacacaeaesd)

Confirm password: Ioonuuu.u..

More about Directory Services Restore Mode password

< Back Next >

Cancel

1.14 Review your selection and click "Next".
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@! Active Directory Domain Services Installation Wizard

Review your selections:
Configure this server as the first Active Directory domain controller in a new forest.

The new domain name is Idap htek.com. This is also the name of the new forest.

The NetBIOS name of the domain is LDAPO

Forest Functional Level: Windows Server 2003

Domain Functional Level: Windows Server 2003

Stte: Default-First-Site-Name

Additional Options: LI

To change an option, click Back. To begin the operation, click Next.

These settings can be exported to an answer file for use with Export setting
other unattended operations. = s |
More about using an answer file

< Back Next > Cancel

The wizard will prompt that the system begins to create the Active Directory Domain
Services.

Active Directory Domain Services Installation Wizard

The wizard is configuring Active Directory Domain Services. This process can take
from a few minutes to several hours, depending on your environment and the options

that you selected.

Waiting for DNS installation to finish

_ Concd |

I~ Reboot on completion;

1.15 Click "Finish" to complete and exit the wizard:
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@1 Active Directory Domain Services Installation Wizard R x|

Completing the Active Directory
Domain Services Installation
Wizard

ive Directory Domain Services is now installed on this _:_]
omputer for the domain Idap htek.com.

is Active Directory domain controller is assigned to the
ite Default-First-Site-Name. You can manage sites with
he Active Directory Sites and Services administrative
ool.

To close this wizard, click Finish.

< Back Finish Cancel l

2. To Install the Active Directory Lightweight Directory

Services Role

You should also install the Active Directory Lightweight Directory Services role on
Windows Server 2008 system.

2.1 Click Start->Administrative Tools->Server Manager.

2.2 Right click "Roles", and then select "Add Roles".

2.3 The Add Roles Wizard will pop up, click "Next".
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Add Roles Wizard y x|
ﬁ‘i Before You Begin
Before You Begin This wizard helps you install roles on this server. You determine which roles to install based on the tasks you
want this server to perform, such as sharing documents or hosting a Web site.
Server Roles
Corifention Before you continue, verify that:
Progress » The Administrator account has a strong password

« Network settings, such as static IP addresses, are configured

Results « The latest security updates from Windows Update are installed

If you have to complete any of the preceding steps, cancel the wizard, complete the steps, and then run the
wizard again.

To continue, dick Next.

I” skip this page by default

< Previous I Next > I Install I Cancel |

2.4 Check the "Active Directory Lightweight Directory Services" checkbox and click
IINextll'

Add Roles Wizard - x|
ﬁé Select Server Roles
Before You Begin Select one or more roles to install on this server.
Server Roles Roles: Description:
AD LDS Active Directory Lightweight Directory
_ ] Atft']ve Dlreit(—)ry C?rhﬁcate Se»rrvices - Services (AD LDS) provides astore for
Confirmation Active Directory Do; e / application-specific data, for directory-
- D Actve Dlrectory Federauon Serwces enabled applications that do not
SarEss ghtweig require the infrastructure of Active
Results [] Active Directory Rjghts Management Services Directory Domain Services. Multiple
[] Application Server instances of AD LDS can exist on a

single server, each of which can have

[[] pHep server its own schema.

DNS Server 'M-.-_f:,‘,;El_"“\
[] Fax Server
[] File Services
(] Hyper-v
[] Network Policy and Access Services
[] print Services
[] Terminal Services
[] upDI Services
[] web server (115)
[] windows Deployment Services

More about server roles

i <Previous| Next > I Instal Cancel

2.5 Follow the default settings and click "Next".
2.6 When the installation is completed, click "Close".
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Add Roles Wizard

ﬁi Installation Results

Before You Begin . X
The following roles, role services, or features were installed successfully:
Server Roles 7
/1 1warning, 1informational me: below
ADLDS L85 arning, Ssages
Confirmation rﬁ Windows automatic updating is not enabled. To install the latest updates, use Windows Update in
%7 Control Panel to check for updates.
Progress
TS Active Directory Lightweight Directory :
esults Fy i

Services i '@ Installation succeeded

@ Instances of AD LDS can be created by launching the Active Directory Lightweight Directory
Services Setup Wizard from the Administrative Tools folder on the Start menu.

Print, e-mail, or save the installation report

< Previous I Next > I Close I Cancel I

After the installation succeeds, you will find the "Active Directory Lightweight Directory
Services" role listed in roles of the server manager.

E, Server Manager

. = [=1p]
File Action View Help
e ARl el 7]
S 5z v
ER=2 A oo/
' Active Directory Domain Sery :
=3 Active Directory Lightweight » View the health of the roles installed on your server and add or remove roles and features.
i, DNS Server 4
Features =
Diagnostics 2
3 3 Configuration R Sy Roles Summary Help
=3 storage

; Roles: 3 of 17 installed 3@ Add Roles

;’),' Remove Roles
Active Directory Domain Services

Active Directory Lightweight Directory Services
DNS Server

@F

[

(~) Active Directory Domain Services AD DS Help

Stores directory data and manages communication between users and domains, induding user logon
processes, authentication, and directory searches.

Go to Active Directory Domain
~) Role Status ES s

Messages: None
System Services: 9 Running, 1 Stopped

/L. Events: 4warnings, 24 informational in the last 24
hours

=l
<] | ]| % LastRefresh: 4/8/2015 10:44:47 AM  Configure refresh

3. Configuring the Microsoft Active Directory Server

To add an entry to the Active Directory:
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3.1 Click Start->Administrative Tools->Server Manager.
3.2 Double click Roles->Active Directory Domain Services->Active Directory Users and

Computers.

3.3 Double click the domain name created above (e.g., [dap. htek.com), and then select

Users->New->Contact.

E,: Server Manager ;IE' EI
File Action WView Help
es 748 XE o= H=
=] g Roles —
% ﬁ Active Directory Domain Services pame — Bipe De.scrlpto Users -
=] : Active Directory Users and Computers [ WINA \l—) Administrator ) User ) Built-n ac More Actions 4
=] 3-‘:’5] Idap.htek. com ..‘Einllowed RODC Password Replica... Security Group ...  Members
| Builtin 52, Cert Publishers Security Group ... Members
| Computers %Denied RODC Password Replicati... Security Group ...  Members
2| Domain Controllers ..J&Dnsndmins Security Group ... DMS Admi
| ForeignSecurityPrincipals ..J&DnsUpdateProxy Security Group ... DNS dieni
. sl ; Delegate Contral. .. %Domain Admins Security Group ... Designate
[HiF Active Dire - %Domain Computers Security Group ... All workst
7" Active Director ces | 82 Domain Controllers Security Group ... All domair
& DNS Server Computer Security Group ... All domair
% Features All Tasks M| Contact Security Group ... All domair
= Diagnostics Group ins Security Group ... Designate
%E Configuration View ' InetOrgPerson d-only Domain Co... Security Group ...  Members
Storage Refresh MSMQ Queue Alias eator Owners Security Group ... Members
Export List... Printer User Built-in ac
) User User
FALEIIE Shared Folder ervers Security Group ... Serversir
Help 54, Read-only Domain Controllers Security Group ... Members
%Schema Admins Security Group ...  Designate
J | | & | ol

|Creates a new item in this container.

New Object - Contact

& Createin:  |dap htek.com/Users

First name:
Last name:
Full name:

Display name:

Inancy

Initials: I“W

lwang

'nancy nw. wang

ok ]

Cancel

3.5 Click "OK" to accept the change, you can see the added contact in the Users field.
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E,= Server Manager =10 |
File Action View Help
€= 7m40(XE d= [HE
= g Roles —
% ﬁ Active Directory Domain Services _Niaﬂe — Type De.m Users :
= :] Active Directory Users and Computers [ WINA | 22 Administrator _ User ) Built-in ac Mare Actions 4
B g Idap.htek.com Sg‘nllowed RODC Password Replica,..  Security Group ... Members
= Builtin Q‘Cert Publishers Security Group ... Members | M@NCY NW. wang <
| Computers $2, Denied RODC Password Replicati... Security Group ...  Members Mare Actions »
2 Domain Controllers .QLDnsAdmins Security Group ... DNS Admi
| ForeignSecurityPrindipals .Q_!,DnsUpdateProxy Security Group ... DNS dieni
- .Q_!‘Domain Adming Security Group ... Designate
[l Active Directory Sites and Services Q‘Domain Computers Security Group ... All workst
=3 Active Directory Lightweight Directory Services E’;_E,Domain Controllers Security Group ... All domair
i DNS Server 2, Domain Guests Security Group ... Al domair
@_'.'] Features 52, Domain Users Security Group ... All domair
? Diagnostics 52, Enterprise Admins Security Group ... Designate
ﬁr& Configuration Q.Q‘Enterprise Read-only Domain Co... Security Group ... Members
5 Storage %Group Folicy Creator Owners Security Group ...  Members
3_; Guest User Built-in ac
3_;. nancy User
Nancy nw., wang Contact
QLRAS and IAS Servers Security Group ...  Serversir
Q‘Read—only Domain Controllers Security Group ... Members
Q‘Sd'lema Admins Security Group ... Designate
| | K | i

4. Configuring Htek IP Phones

LDAP is disabled on IP Phones by default. You can configure LDAP via web interface or

using configuration files. The feature is supported version 1.0.3.82 or later.

To configure LDAP feature via web user interface:
4.1 Press the "OK" key on the phone when it is idle to obtain the IP address.

4.2 Enter the IP address (e.g., http://192.168.0.100 or 192.168.0.100) in the address bar
of web browser on your PC and then press Enter.

4.3 Enter the user name and password in the login page.

4.4 Click on Directory->LDAP.
4.5 Enter the desired values in the corresponding fields.

The default login user name is admin (case-sensitive) and the password is admin

(case-sensitive).

The screenshot for reference is shown as below:
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logout

Home | Account | Network | Function Keys | Setting |

Derectory LOWP Mame Filter [cn=%) T

Remote Phone

Book LDWP Mumber Filter {[itelephoneMumber="%) E
Call History erver ABEress 192.1680.191 2
ot 389 T
Metwork
Directory ase de=ldap,dc=htek dc=co *
F———— ser Mamea cn=Administrator,cn=Us T
assword TTTITITY T
Max Hits(1~32000) 32000 ?
LDAP Name Aftributes cn sn displayName ?
LDAP Number Attributes honeNumber homePho 2
LDAP Display Name %an %sn ?
Search Delay(0~2000ms) ?
Protocol (0 Version2 @ Version3 ?
LDAP Lookup For Call @ on D oft 2
LDAP Sorting Resuts @ on Oofr 2
LDAP Synchronize Time(0~3993mins) v
SaveSet | [ CGancel

4.6 Click "SaveSet" to accept the change.

5. LDAP Attributes on Web Interface

LDAP Name Filter: This parameter specifies the name attributes for LDAP searching.

The “%” symbol in the filter stands for the entering string used as the prefix of the filter

condition.

For example (cn=%), when the name prefix of the cn of the contact record matches the
search criteria, the record will be displayed on the IP PHONE LCD.

LDAP Number Filter: This parameter specifies the number attributes for LDAP
searching.

Server Address: Fill the domain name or IP address of the LDAP Server.
For example: 192.168.0.191

Port: Fill the port of the LDAP Server, for example: 389 as default.

Base: Fill the same value as suffix value mentioned before.
For example: dc=HanLong,dc=com

User Name: Fill the same value as rootdn mentioned before.
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For example: cn=manager,dc=HanLong,dc=com

Password: Fill the same value as the rootpw mentioned before.
For example: secret

Max.Hits: the maximum number of the search results to be returned by the LDAP server.
LDAP Name Attributes: Fill the LDAP Name Filter, separated by a space between two
values. If you set this attribute, the LDAP Server will send the name attribute to SIP Server,
for example: cn

LDAP Number Attributes: Fill the LDAP Number Filter, separated by a space between
two values. If you set this attribute, the LDAP Server will send the number attribute to SIP

Server, for example: telephoneNumber

LDAP Display Name: Fill the display name of the contact record displayed on the LCD
screen, separated by a space between two values, for example: %cn %sn

Filled the relative value and then click "SaveSet" button to save the settings.
Following is the example screenshot for the configuration.

Example for Configuration

LDAP Name Filter: (J(cn=%)(sn=%))

LDAP Number Filter: (|(telephoneNumber=%)(Mobile=%)(ipPhone=%))
Server Address: 192.168.0.191

Port: 389

Base: dc=Idap,dc=htek,dc=com

Username: cn=Administrator,cn=Users,dc=ldap,dc=htek,dc=com
Password: secret

Max Hits (1~32000): 32000

LDAP Name Attributes: cn

LDAP Number Attributes: Mobile telephoneNumber ipPhone
LDAP Display Name: %cn

Protocol: Version 2

LDAP Lookup For Incoming Call: off

LDAP Sorting Results: off

6. To Use LDAP feature

To configure an LDAP key via web user interface:
6.1 Log into the web interface of the phone.
6.2 Click on Function Keys->Memory Key (or Line Key).
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6.3 In the desired memory key (or line key) field, select LDAP from the pull-down list of
"Type".

logout

Home | Account | Network | | Setting | Directory | Management

- Label Account Pickup Code NOTE
Keyl  Line - | [4ute = |
Key2  Line - | [4uto T= |
Keyd  Line - | [4uta [=
|Keya  LDaP ~ | | | uto | |

6.4 Click "SaveSet" to accept the change.
6.5 Press the LDAP key on the phone when it is idle. The LDAP contacts will display on
the LCD:

LDAP Contacts 1/2

nancy nw. wang 789456
clyde wu 123123

Filter Prefix: |

Cancel 2aB

6.6 You can search contacts by entering character in the Filter Prefix field.
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